Forums  ›  Cheetah  ›  Bug Reports

Member Menu Builder Not Working

I could do some screenshots.  I tested on the old 7.1.6 site and the area where you can click and drag is different; you can click and drag at the bottom of the button.  However, I also tested on the Windows 7 with the latest FireFox; it could be that changes to the way the new FireFox is processing the JS for the click and drag is a bit different.  It shouldn't change to the cross arrows on regions of the button that one can't click to drag and it is.  That is what was helping to confuse me.  At least I know now how to proceed.

Ok. I will still need to do some testing on linux.

But part of that is normal. The text is a clickable item and not a draggable item so it is normal to not be able to drag while on a clickable link.

However the cursor should switch from pointer to drag arrows as you move from the link to the button to indicate the button is draggable.

For me it does this properly on all the menus including the navigation menu. But for you it is apparently not. So there is still a issue somewhere.

I have figured it out by just playing around.  I started the Windows 7 virtual machine and notice the same issue.  I upgraded FireFox for Windows to the latest edition and then logged into the site.  I would hover over the item and on that version I get the cross arrows instead of the hand but couldn't move the item unless I was directly over the cross item on the item button.  Once over the cross arrows, I am able to click and drag the item.  On the page menu, it is still the same, as long as you are not on the text, you can click and drag the item.  However, in the navigation builder, I have to be over the cross arrows to the left of the text to drag the item.  I tested back on the linux box and it is the same, I have to be over the cross arrows to click and grab and drag the item.


I will setup a mint desktop as soon as i can to run some tests with.

You may just decide to stay with Linux

I decided to see if the Dolphin demo site would be the same and it is.  I don't know the last time I worked with navigation menus.

I have virtual box installed on the Linux box.  I am going to log into the Windows 7 machine and see what happens.  If that allows me to work on the menus then I may just ignore this for now.  I am planning on rebuilding my Linux box when I can have some time to take it down.  I have an old slow Windows Server 2008 box that I might set up again so I can free this machine up.  Most of my old boxes are antiques now.

It has to be machine related in some way.  The FIreFox browser did have an ad block but I disabled it and it made no difference.  I have seen adblock screw up sites.

Only difference i can see at the moment is Linux browser versions vs Windows browser versions.

So i guess i will need to get a Linux desktop setup to test with.

Maybe there is a difference on how javascript is handled between Windows and Linux. In any case the drag and drop features of those menus is javascript so that has to be the area to look at. If JS compression is on on any of those sites, try shutting it off.

I will setup a mint desktop as soon as i can to run some tests with.


I have tried it on latest versions for windows of Firefox, Chrome and Opera and had no problems.

That means it is local to me.  I am running on Linux Mint, not up to date.  On FireFox; which is updated to the latest for Linux, a Dolphin site has the issue.  I did wanted to confirm so tried it on  a Cheetah site on the Opera browser and it wouldn't work.  The Dolphin site is on a different server than the Cheetah site; both dedicated servers that I manage.

Just checked as I type this and the pages builders are working in Cheetah, I can move items around.  However, the main navigation is the same, unable to move items around.

OK, this is strange, the same issue is happening on a  Dolphin site and  a Cheetah site on two different servers and two different browsers for the navigation menus but not the page builder.  I am stumped; what could cause this?  Anyone?

I guess this can be moved from the bug report forum.

So far unable to reproduce.

I have tried it on latest versions for windows of Firefox, Chrome and Opera and had no problems.

Ok, thanks. I'll look into it.

By the way, this is the same for Dolphin 7.4.2; so this bug is inherited from Boonex.  I just never noticed before because I have not worked with the member menu bar in the past.  I wanted to look at adding a custom item for a Dolphin site I am working on and found the bug; tested it on the current stable Cheetah site and it was there as well.

I went to add an item to the member bar menu and the builder does not let me drag NEW ITEM into place or rearrange any current items.  I can click on the active items and see the properties but that is about it.  I guess if I want to add something I will have to look at doing it through the database.

Forums  ›  Cheetah  ›  Bug Reports