Forums  ›  Cheetah  ›  Bug Reports

Can't add a photo to a table using HTML block.

I'm not in a hurry so do it when you can. I'll message the details later tonight.

I will need to look things over on your server. It will be a few days before i can get to it. One of my days off. Either Sunday or Monday.

I'm not sure what happened to the permissions. All folders were set to 777. I reinstalled the script and all was well.

I can't see any indication that selinux is running on my server. I ran a few commands including 'sestatus'  from various tutorial sites and it says the command isn't recognised.

I added the .htaccess file. Cleared caches and cookies. No improvement.


There isn't any .htaccess file in /tinymce_uploads

Then try creating one. Make a copy of the .htaccess that in media/images/profile and copy it to media/images/tinymce_uploads

This appears as if this might be a issue with selinux which i normally don't install on production servers due to the issues it can cause.

I've reinstalled the original script because the permissions on the first install went crazy.

If php is running as a FPM application then there should not have been any issues with permissions as you should not have had to set any except for the executable permission of ffmpeg.

I don't have mod_security. Just a server firewall which seems to look after itself.

These are the only error messages thus far.

[Wed Jan 26 01:02:46.746612 2022] [core:crit] [pid 927:tid 140239020463872] (13)Permission denied: [client] AH00529: /home/xx/web/ pcfg_openfile: 

There isn't any .htaccess file in /tinymce_uploads

Only postAccelorator.php


unable to check htaccess file, ensure it is readable and that '/home/xx/web/' is executable, referer:


Tinymceuploads has permissions of  755

/manager/ looks like it refers to my my file manager

I've reinstalled the original script because the permissions on the first install went crazy.

Your'e welcome to look at the site.


I would check all of the server logs to see if it shows a reason for the 403 error.

Also do you have any security software such as modsecurity installed? If mod security is installed you could try creating a .htaccess file in the folder media/images/tinymce_uploads And put this in that .htaccess file.

<IfModule mod_security.c>
SecFilterEngine off

Also, delete the folder that was created to put the image in before testing again so the upload will have to recreate it.

Thanks Deano,

I uploaded the files, rebooted the server, cleared Browser and Cheetah Caches/Cookies and now it's showing:

HTTP: 403 Error.

As it works on the Wamp server and your site, I'm guessing something on my server is blocking it. What I find interesting is that a folder has been created to accept the image, but the image itself is being blocked. I'm able to upload images with the Photos module okay.

TinyMCE has been updated to version 5.7.1

It will be in the next version. You can also download a current snapshot from github and extract it to get the updated tinymce from that snapshots plugin folder.

Yes. I saw that report also during my research.

As stated, that only happens if a error with the upload occurs. So i need to try and figure out why it is failing. The new version TinyMCE 5.7.1 is out which is suppose to fix that issue, so i will be putting that into the next update to cheetah.

EDIT: Which of course does not actually solve anything except allowing tinymce to show you the error.

I tried updating Java on my computer. That didn't help. It seems [object Object] is a bug in the latest version of TinyMce:

That doesn't help either.


For what it's worth, I don't have mail or Cron set up on the test servers yet. Could that have something to do with it?

No. It should not have any affect of that. I also have not figured out what could be causing it.

No joy at this stage. I've just installed a new server running Ubuntu 20 PHP7.4 and Marina db The Cheetah Host Tools aren't showing any fails except the usual cache fails.

I had two installs of Cheetah on the old server and the problem existed on both. I've only got one install running at present, but I'll create a new install when I get time. As I said earlier. It's working fine on my PC's wamp server.

For what it's worth, I don't have mail or Cron set up on the test servers yet. Could that have something to do with it?

Yes it's there. I'm off to bed (2am). I'm looking at changing my control panel and that may help. 

Verify the presence of the folder media\images\tinymce_uploads

And in that folder should be a file named postAcceptor.php

It works fine on my WAMP server. It allowed me to see the path for saving the photo. The Media section has permissions of 755 throughout. I changed them to 777, but no improvement. they're now back to 755.

I'm guessing it's a permissions thing. 

This one will not be easy to track down. I have not been able to reproduce it on any of my test sites. They all work fine.

Apologising in advance if I've overlooked a response.

I've added a HTML block to the home page and created a two column table. Text goes in one column okay, but when I try to upload or drop a photo I get this screen:

It works fine on my Dolphin site and it works fine on this forum as well. The table without the photo also appears okay on the home page.

Test photo


Forums  ›  Cheetah  ›  Bug Reports